NextGEN Gallery runs best on Linux servers, preferably a WordPress recommended server listed here: http://wordpress.org/hosting/ and our recommended hosting providers like Siteground, but it will run well on any wordpress-friendly server with the following WordPress.org required settings in place:

  • PHP version 7.2 or greater
  • MySQL version 5.6 or greater
  • HTTPS support
  • The mod_rewrite Apache module

Confirm with your hosting provider that you have set in your installed php.ini file:

  • PHP Safe Mode turned OFF
  • At least 250MB memory allowed
  • 30MB or larger upload limit
  • 30MB or larger post limit

Other settings to check:

  • 755 permissions set on /wp-content directory.  If your hosting environment requires higher than 755, you risk being vulnerable to hackers. This is a sign of a less supportive web host for WordPress. You should NEVER have to go as high as 777
  • GD Library enabled and activated on your hosting account

With the above settings in place, please note that we can't test every server available on the market. We build and test the plugin on WordPress recommended servers as mentioned above, and know that our plugin works well in their server environments. They have the necessary server settings in place and cater to the WordPress software well. If you experience any major issues with the plugin on your server, please send in your bug report to our developers here: https://www.imagely.com/report-bug/

Close Menu
[i]
[i]
[i]
[i]